We have fixed the issue and AT&T seems to have fixed their issue as well. We will restore all previous checkouts to users and will reopen the merch store soon.
Posted Feb 22, 2024 - 22:49 UTC
Investigating
Customers have reported that online sales are not going through. Our sales team has reported that there is an issue with payments and fulfilling orders.
Posted Feb 22, 2024 - 16:05 UTC
This incident affects: Merch Store and Sales Department.